Lenkwinkelsensor

Fragen zur Elektrik, Radio und Navigation

Moderatoren: Robschi, mfl, 57belair, mchen

Lenkwinkelsensor

Beitragvon freistil » Sa 13 Nov, 2021 09:59

Hallo Zusammen,

ab und zu leuchtet bei meinem SL 320 Bj 1999 die ABS-Lampe auf, dann geht auch der Tempomat nicht. Manchmal geht sie auch wieder aus ... unregelmäßig. Fehlerspeicher sagt: Lenkwinkelsensor. Das Problem besteht schon seit langem, es nervt halt inzwischen. Nun habe ich gelesen, dass der Lenkwinkelsensor nach Batterieausbau "angelernt" werden muss. Das habe ich nie getan und es wäre deshalb mein erster Schritt, das nachzuholen. Auf der anderen Seite wäre ja logisch, dass die ABS Lampe dann immer leuchtet, bis der Sensor angelernt ist, oder nicht?

Wie genau muss ich da vorgehen? zum anlernen?

Falls das nicht hilft: Wo sitzt der Sensor, und wie tauscht man ihn? > zweiter Schritt ...

Besten Dank für Eure Tipps!

Chris
Gute Fahrt! Chris

SL320, Mopf2, Bj. 1999.
freistil
 
Beiträge: 97
Registriert: Do 12 Mär, 2015 11:36
Wohnort: Dresden

Re: Lenkwinkelsensor

Beitragvon Raggna » Sa 13 Nov, 2021 11:32

Hallo Chris,
nicht nur der Lenkwinkelsensor muß angelernt werden, auch die Fensterheber!
- Stand der Technik damals....
Dreh die Lenkung einfach vom einen zum anderen Anschlag, bei eingeschalteter Zündung und Motor. :-)
Fehe einmal runter, halten, 3sek und wieder hoch, auch da 3sek halten.
Fretig.
Gruß
Th.
Raggna
 
Beiträge: 719
Registriert: So 11 Feb, 2007 16:53
Wohnort: nähe Wiesbaden

Re: Lenkwinkelsensor

Beitragvon freistil » Sa 13 Nov, 2021 14:04

Hallo Th,

das mit den Fensterhebern wusste ich, merkt man ja beim Türen schließen ... muss das anlernen LWS gleich beim wieder neu die Batterie anschließen geschehen oder ist es egal wann??

GRuß, C
Gute Fahrt! Chris

SL320, Mopf2, Bj. 1999.
freistil
 
Beiträge: 97
Registriert: Do 12 Mär, 2015 11:36
Wohnort: Dresden

Re: Lenkwinkelsensor

Beitragvon Raggna » Di 16 Nov, 2021 10:03

Hallo Chris,
das ist wie bei den Fensterhebern.
So lange der Computer nicht weiß wo er ist, bleibt er im Notlauf.
Drum wundert mich das Du das Problem nur zeitweise hast?
Notlauf ist blöd... besser ist anlernen....
Gruß
Th.
Raggna
 
Beiträge: 719
Registriert: So 11 Feb, 2007 16:53
Wohnort: nähe Wiesbaden

Re: Lenkwinkelsensor

Beitragvon HPX » So 21 Nov, 2021 22:37

Hallo Chris,

Dass das Anlernen des Lenkwinkelsensor dein Problem löst, halte ich für sehr unwahrscheinlich. Angelernt werden muss immer dann, wenn die Spannungsversorgung zum LWS unterbrochen war. Die Kontrollleuchte geht dann aber auch nicht von alleine aus, wenn wieder Spannung da ist, sondern bleibt an bis der LWS wieder angelernt wurde.

Ich entnehme deiner Beschreibung, dass die Leuchte auch wieder von alleine ausgeht.
Dies ist bei fehlendem Anlernen definitiv nicht der Fall.

Wenn in deinem Fall die Kontrollleuchte tatsächlich nach Anlernen wieder ausgehen würde, wäre auch nur das Symptom behoben aber nicht die Ursache (= Spannungsunterbrechung).

Ich fürchte dein Problem ist etwas komplexer. Zuerst solltest du versuchen herauszufinden, ob es tatsächlich zufällig auftritt oder sich mit etwas anderem verbinden lässt (z.B. Lenken, Bremsen, Warm, Kalt etc.)

Mich verwundert auch etwas, dass nur die ABS Leuchte erwähnst. Bei einer Fehlermeldung zum Lenkwinkelsensor leuchtet nicht nur die ABS Leuchte, sondern auch die für das ESP. Dafür braucht es den LWS nämlich. Leuchtet die ESP Leuchte bei dir, wenn du die Zündung einschaltest und geht dann aus? Evtl. ist ja die Birne defekt?

Die Fehlermeldung "Lenkwinkelsensor" heißt übrigens nicht unbedingt, dass dieser defekt ist. Das ist er nämlich meist nicht. Wäre nicht das erste Mal, dass der Sensor für viel Geld getauscht wird aber das Problem irgendwann wieder kommt.
Es bedeutet erstmal nur, dass das Steuergerät kein oder ein nicht plausibles Signal vom LWS erhält. Vor dem Sensortausch sollte man erst mal versuchen andere Fehlerquellen auszuschließen. Das können leider einige sein, inkl. dem Steuergerät selbst. Nur mal so zwei Gedanken (die es tatsächlich so schon gab):

Ein Kabelbruch in der Leitung zwischen LWS und Steuergerät kann z.B. absolut sporadische Ausfälle verursachen. Je nachdem, ob das Signal durchkommt, leuchtet die Kontrollleuchte oder eben nicht. Am besten das Kabel durchmessen, wenn die Leuchte an ist oder parallel provisorisch ein zweites Kabel anschließen und testen. Das tückische in diesem Fall ist, dass durch ein Tausch des Sensors meist das Kabel bewegt wird und es zufällig wieder geht. Aber halt nur kurzzeitig.

Ein anderes Thema ist die Einbauposition von LWS und Kontaktspirale. Die Mopf2 sind hier wohl recht sensibel. Kann vor allem dann ein Problem sein, wenn schon mal am Blinkerhebel gebastelt oder dieser getauscht wurde. Ist alles fest und im Originalzustand?
Wenn man es ganz genau prüfen will, es gibt im WIS auch ein genau definiertes Maß für die Position von Kontaktspirale zu Mantelrohr - mit einer Toleranz von +/- 0,5mm.

Um dem Problem auf die Spur zu kommen braucht es neben etwas detektivischem Spürsinn auf jeden Fall eine Stardiagnose, die entsprechenden Schaltpläne und Zeit. Wenn es eine Werkstatt machen soll wohl auch noch ein paar große Scheine.

Viel Erfolg.

Grüße
Heiko
HPX
 
Beiträge: 130
Registriert: Fr 08 Jun, 2018 11:21
Wohnort: Baden

Re: Lenkwinkelsensor

Beitragvon freistil » Mo 06 Dez, 2021 18:15

Vielen Dank Euch für Tipps und Hinweise.

Natürlich hat das anlernen nichts gebracht.
Inzwischen geht die BAS/ESP und ABS Leuchte bei jeder Fahrt nach einigen Sekunden/Minuten an. Tempomat geht dann nicht.

Vor längerem wurde mal bei diesem Problem der Druckschalter Bremslicht (Bremspedal?) ausgewechselt; das war günstig und hat geholfen, die Technik funktionierte bei Vollbremsung einwandfrei. Das wäre meine erste Frage: kann das sein? Wo sitzt das Ding? Unterm Pedal?

Weitere Fragen: Wenn der Sensor/ Spirale nicht korrekt justiert sind, wie Heiko vermutet, was tun?? Wo sitzt er? Blinkerhebel wurde m. E. noch nie ausgebaut. Alles einwandfrei.
"Wenn man es ganz genau prüfen will, es gibt im WIS auch ein genau definiertes Maß für die Position von Kontaktspirale zu Mantelrohr - mit einer Toleranz von +/- 0,5mm."
... da müsste ich erst mal wissen, wo er sitzt ;)

Ich bin nicht so Schraub-versiert, mache hier und da was, und weiß nicht mal, was das WIS ist ... Danke für Aufklärung! ... und für weitere Hilfe auch.
Gute Fahrt! Chris

SL320, Mopf2, Bj. 1999.
freistil
 
Beiträge: 97
Registriert: Do 12 Mär, 2015 11:36
Wohnort: Dresden

Re: Lenkwinkelsensor

Beitragvon sl 600 » Mo 06 Dez, 2021 19:33

Den LWS kann mit einer Stardiagnose leicht überprüft werden ( Istwerte ) , reines Fehlerauslesen und löschen sagt fast nichts aus !!
Wer sich nur auf Fehler XX verlässt und das Teil daraufhin erneuert , hat am ende eventuell eine menge teure und nicht defekte Teile getauscht.
Auch der Bremslichtschalter ist über Istwerte überprüfbar.
Bei deinem Problem sind unzählige Komponente die in Betracht kommen.
Gruß Luis
BildBildBildBildBildBild




Bild
Benutzeravatar
sl 600
Site Admin
 
Beiträge: 9384
Registriert: Sa 13 Mai, 2006 21:03
Wohnort: Duisburg

Re: Lenkwinkelsensor

Beitragvon HPX » Di 07 Dez, 2021 10:45

Luis hat recht. Nur eine systematische Fehlersuche mit Stardiagnose bringt dich weiter. Teile auf Verdacht tauschen ist so teuer wie erfolglos.

von freistil » 13. November 2021 08:59
Fehlerspeicher sagt: Lenkwinkelsensor.
.

Da hast du ja schon einen Ansatz. Wurde das mit einer Stardiagnose ausgelesen und hast du Zugang dazu? Dann schau dir als nächstes die Ist-Werte an wie Luis schreibt. Wäre der BLS defekt, sollte er übrigens auch im Fehlerspeicher stehen.


Heiko
HPX
 
Beiträge: 130
Registriert: Fr 08 Jun, 2018 11:21
Wohnort: Baden


Zurück zu Elektrik, Radio und Navigation

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 3 Gäste

cron